Child pages
  • clazzes.org Web Application Bundles

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Migrating projects from http-util versions prior to http-util-1.5.0

  1. Upgrade dependencies to http-util-1.5.0 and gwt-osgi-2.4.0.2, if applicable.
  2. Move all your deployed resources in the bundle from /WEB-INF to /OSGI-INF/webapp
    This might incur checking your service.xml and your pom.xml , maybe you have to move resources inside src/main/resources
  3. Remove instances of BasicHttpContext
    This includes removing the httpContext property from your HttpServiceRegistrationListener bean.
  4. Add an appropriate resourceClassLoaderHint to your ResourceServlet bean. (See the hints above for more explanations)

...