Child pages
  • Adapting FancyLibs & MinGW-Pkg from Debian 9 Stretch to 10 Buster, Mingw-7 to Mingw-8

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Fixed fancymodbus build

...

Project (subdir)Archs (-o parameter)Remarks generalStatus & Remarks stretch/busterVersion with Buster
fancylogarch|8
OK.
in pba-rpmrelease, call to rpmsign can be reduced to:
rpmsign --addsign -v --key-id 9...7 -D "%__gpg /usr/bin/gpg" ../foobar-1.2.3-1.src.rpm
1.0.3-5
cute-headersarch|8Data only, could be done anytimeOK1.6.1-9
fancylibsarch
OK. libstdc++-8-dev3.7.3-1
fancydb-Unix onlyOK0.6.5-7
fancydrawingarch
OK0.6.2-3
fancygpsdclientunix
OK0.4.3-5
fancyhttpdarch
OK0.8.0-2
fancylogdunix
OK0.1.0-3
fancylogview.Debian unix & amd64 onlyHalf OK: Does not build for armhf, maybe never did, libqt4-dev seems incomplete for arm0.3.0.5
fancypkcs11unixDebian unix & amd64 onlyHalf OK: Does not build for armhf, maybe never did0.4.1-1
fancypcscunixDebian unix & amd64 onlyHalf OK: Does not build for armhf, maybe never did0.2.5-2
fancymodbusunixNOK

Diverse library-Anpassungen nötigOK
Required minor adaption, with libmodbus-dev going from 3.0.6 to 3.1.4
0.2.4-3+
fancysaxarch
OK0.6.1-7
fancyqt4arch
OK0.9.3-3
fancyqt4widgetsarch
OK0.5.2-2
fancysaneunix
OK, but libsane-dbg not available for buster. Reduced that to suggestion0.3.2-5
fancyqmiunixDebian unix & amd64 onlyHalf OK: Does not build for armhf, maybe never did0.2.1-5
fancyssl-toolsunix
OK?0.4.0-5

...